В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от −10 000 до 10 000 
включительно. Определите количество пар последовательности, в которых только одно число оканчивается на 3, а сумма квадратов 
элементов пары не меньше квадрата максимального элемента последовательности, оканчивающегося на 3. В ответе запишите два числа: 
сначала количество найденных пар, затем максимальную из сумм квадратов элементов таких пар.
 В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

file = open('G:/17.txt')
mass = [int(x) for x in file]
maxX = 0
maxAB = 0
all = 0
for i in mass:
    tmp = (i % 10)
    if tmp==3 and i>maxX:
        maxX = i
for x in range(len(mass)-1):
    if (((abs(mass[x])%10 == 3) and (abs(mass[x+1])%10 != 3)) or ((abs(mass[x+1])%10 == 3) and (abs(mass[x])%10 != 3))) and ((mass[x]**2 + mass[x+1]**2)>=maxX**2):
        all+=1
        if mass[x]**2 + mass[x+1]**2>maxAB: maxAB=mass[x]**2 + mass[x+1]**2
print(all,maxAB)